menu more_vert help_outline Support person_outline Sign in Create account

get_app Download free Globus application

Windows 7/8/10 or later version (version: 6.0.7.1 )

If the application automatic installation failed:
1. Install .NET Framework 4.5.
2. After that install the application manually.

Attention! If the program can not be installed or started.
  1. Temporarily disable the antivirus;
  2. Remove the previous applications using your Windows Control Panel;
  3. Install the application from the site;
  4. Add it to the antivirus exceptions.
If something does not work:
  1. disable the ad blockers such as AdBlock, µBlock, Adguard or analogs;
  2. clean up the garbage using our script, and after that install the application.
Windows 7/8/10 or later version (version: 7.0.0.5, recommended )

If the application automatic installation failed:

  1. Download and install .NET Framework 4.5.2.
  2. Download and install Visual C++ Redistributable Packages for Visual Studio 2013.
  3. Download and install our application manually.
Attention! If the program can not be installed or started.
  1. Temporarily disable the antivirus;
  2. Remove the previous applications using your Windows Control Panel;
  3. Install the application from the site;
  4. Add it to the antivirus exceptions.

If something does not work:
  1. disable the ad blockers such as AdBlock, µBlock, Adguard or analogs;
  2. clean up the garbage using our script, and after that install the application.
Windows XP

Sometimes the Microsoft .NET Framework 4.0 Client Profile is required. In this case, download it from the Microsoft official server.

Minimum requirements: Internet Explorer 7 or later version.

Attention! If the program can not be installed or started.
  1. Temporarily disable the antivirus;
  2. Remove the previous applications using your Windows Control Panel;
  3. Install the application from the site;
  4. Add it to the antivirus exceptions.
If something does not work:
  1. disable the ad blockers such as AdBlock, µBlock, Adguard or analogs;
  2. clean up the garbage using our script, and after that install the application.
Android

Requirements: Android 4.0.3 or later.
You can as well install local version of the software.
To install local version (not from the Play Market) see the Section "Technical issues" of the FAQ.

iOS

Requirements: iOS 10.2 or later.
Compatible with iPhone, iPad and iPod touch.

?
translate Language: English
new_releases {1}
{2}